CollabVM Server 1.x/ARM port

From Computernewb Wiki
Jump to navigation Jump to search
Obsolete.png This page references older versions of CollabVM and its server, therefore, (some parts, or the entirety of) the information is irrelevant to the current version of the software.

An ARM port for collab-vm-server has been released on December 3rd, 2018, thanks to the efforts of CHOCOLATEMAN and ir0nlake.

The ARM port for CollabVM Server 1.2.7 is identical to the i686/amd64 versions of collab-vm-server that are currently available. The only difference is that the "setup" page states that it is running on armhf hardware, rather than x86 hardware. Other than that, it is virtually identical in basically every way to x86 version. Currently, the only version of collab-vm-server that is available is version 1.2.7. However, older versions are expected to compile and run on the ARM architecture as well. This is untested and is not supported.

Currently, the armhf port of collab-vm-server has been compiled and tested on the Raspberry Pi 3 Model B. While it is expected to work with the other models of the Raspberry Pi, such as the Raspberry Pi 1, 2, and Zero, this has not been tested. It is not guaranteed to work on other machines either, even if it runs on the ARM architecture.

This port has only been tested on Raspbian, and is not guaranteed to work with other distributions of Linux on the Pi, e.g. Arch Linux or Fedora.

An additional dependency is required for the ARM version of collab-vm-server, which is libossp-uuid-dev. You will need to install this before you can start the server. Other than that, the dependencies are the exact same as the x86 versions.